Results 1 to 3 of 3
  1. #1
    Tom
    Guest

    Video Streaming In Tomcat

    Hi,
    I am wanting to do video streaming within a system I am making,
    I have a some JSP's running on a Apache Tomcat server and am wanting to link to the video stream.
    This tutorial was helpful and I have just got a real player stream setup and am linking through the .ram file.
    If I doubble click the .ram file it streams the movie but if I link to it it just displays the text within (the link to the .rm file).
    If I just link to the .rm file it works but obviously downloads it.
    Got any ideas how to get the .ram file to link not display text?
    It would be a great help
    Tom

  2. #2
    Tom
    Guest

    Video Streaming In Tomcat continued

    I have just managed to get something different if the video stream is put into .wmv it just outputs a bunch of strange characters like if you try to open a media type with word e.g.


    0&uf٪bl@ ^PAspectRatioXAspectRatioY
    WMFSDKVersion10.00.00.3646WMFSDKNeeded
    0.0.0.0000 IsVBRܫG SehǟPA0֪؛(E+LJ @ dd_. Se/ӫ SeFC|K)9>A\' en-gb]&EG_eRů[wHgDLZ IsVBR4DeviceConformanceTemplateL2 IsVBR4DeviceConformanceTemplate@.
    WM/WMADRCPeakReference4
    WM/WMADRCAverageReferencet E˖˥r2CiR[ZX ' 'E)˥r2CiR[ZXUU c ު|O(Uݘ&@Rц1 HARц1 HWindows Media Audio 9.1" 10 kbps, 11 kHz, mono 1-pass CBRaWindows Media Video V8WMV2ܷ



    Has anyone else recieved this problem? Is it something to do with Tomcat? Please help

  3. #3
    thor
    Guest
    Check your mime-types file on the server. It should have entries for the relevant data types:

    Code:
    audio/x-pn-realaudio            ram ra

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Subscribe to us on YouTube