I can't visit www.mixmed.com from my work computer. It works from any other location. Does this trace reveal the problem? If not, what could it be? WOuld replacing the modem solve anything?

Tracing route to 35.136.178.205.netsolvps.com [205.178.136.35]
over a maximum of 30 hops:

1 * * * Request timed out.
2 10 ms 16 ms 28 ms ge-3-37-sr01.fernandina.fl.jacksvil.comcast.net
[68.86.170.93]
3 11 ms 16 ms 8 ms te-9-3-ur01.yulee.fl.jacksvil.comcast.net [68.85
.225.89]
4 13 ms 12 ms 11 ms te-9-1-ur01.springfield.fl.jacksvil.comcast.net
[68.85.225.93]
5 14 ms 12 ms 11 ms te-8-2-ur01.edgewood.fl.jacksvil.comcast.net [68
.86.168.74]
6 15 ms 25 ms 15 ms te-9-3-ar01.westside.fl.jacksvil.comcast.net [68
.86.168.81]
7 12 ms 16 ms 10 ms te-9-3-ar01.southsiderdc.fl.jacksvil.comcast.net
[68.86.168.122]
8 20 ms 16 ms 27 ms te-7-1-ar01.pompanobeach.fl.pompano.comcast.net
[68.85.229.213]
9 36 ms 32 ms 29 ms te-7-1-ar02.augusta.ga.augusta.comcast.net [68.8
5.229.214]
10 39 ms 34 ms 35 ms 68.86.85.214
11 41 ms 44 ms 42 ms pos-0-12-0-0-cr01.atlanta.ga.ibone.comcast.net [
68.86.85.213]
12 46 ms 37 ms 55 ms te-4-4.car1.Atlanta2.Level3.net [4.71.252.13]
13 49 ms 38 ms 52 ms ae-72-52.ebr2.Atlanta2.Level3.net [4.68.103.61]

14 67 ms 71 ms 70 ms ae-3.ebr2.Chicago1.Level3.net [4.69.132.73]
15 64 ms 72 ms 64 ms ae-4-4.car2.StLouis1.Level3.net [4.69.132.189]
16 67 ms 67 ms 72 ms ASIA-NETCOM.car2.StLouis1.Level3.net [63.208.32.
186]
17 237 ms 141 ms 130 ms sw3sw2.cybercon.net [216.15.195.69]
18 65 ms 70 ms 65 ms GigE1NSolB.cybercon.net [64.37.126.222]
19 68 ms 65 ms 69 ms edg-r-01-vlan10.net.cyb.netsol.com [205.178.184.
14]
20 65 ms 70 ms 64 ms vps-fw-01.net.cyb.netsol.com [205.178.184.69]
21 * * * Request timed out.
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
26 * * * Request timed out.
27 * * * Request timed out.
28 * * * Request timed out.
29 * * * Request timed out.
30 * * * Request timed out.