Results 1 to 7 of 7
  1. #1

    installation of swf to website problem

    Hi,

    When I install and test the player on localhost, all works exactly as it should. When I modify the code to my website, then nothing happens at all. Any ideas on where I'm going wrong? Code for both posted below:

    LOCALHOST version -- works perfectly.

    <!-- MC Media Player -->
    <script type="text/javascript">// <![CDATA[
    playerFile = "http://localhost/KateysFirearmsFacts.com/mcmp_0.8.swf";
    fpFileURL = "http://localhost/KateysFirearmsFacts.com/video/CFC_Repeatedly_Registers_Stolen_Gun.flv";
    playerSize = "360x270";
    playerBackgroundColor = "cccccc";
    fpAction = "play";
    fpButtonColor = "ff00";
    defaultEndAction = "pauseAtStart";
    cpBackgroundColor = "ff66ff";
    cpButtonsOpacity = "75";
    cpPlayBtnColor = "ff00";
    cpStopBtnColor = "ff0000";
    cpVolumeCtrlColor = "ffff00";
    cpScrubberElapsedColor = "ff00ff";
    cpVolumeStart = "75";
    cpHidePanel = "never";
    // ]]></script>
    <script src="http://localhost/KateysFirearmsFacts.com/mcmp_0.8.js" type="text/javascript"></script>
    <!-- / MC Media Player -->



    WEBSITE version -- does not load player or video

    <!-- MC Media Player -->
    <script type="text/javascript">// <![CDATA[
    playerFile = "http://www.KateysFirearmsFacts.com/mcmp_0.8.swf";
    fpFileURL = "http://www.KateysFirearmsFacts.com/video/CFC_Repeatedly_Registers_Stolen_Gun.flv";
    playerSize = "360x270";
    playerBackgroundColor = "cccccc";
    fpAction = "play";
    fpButtonColor = "ff00";
    defaultEndAction = "pauseAtStart";
    cpBackgroundColor = "ff66ff";
    cpButtonsOpacity = "75";
    cpPlayBtnColor = "ff00";
    cpStopBtnColor = "ff0000";
    cpVolumeCtrlColor = "ffff00";
    cpScrubberElapsedColor = "ff00ff";
    cpVolumeStart = "75";
    cpHidePanel = "never";
    // ]]></script>
    <script src="http://www.KateysFirearmsFacts.com/mcmp_0.8.js" type="text/javascript"></script>
    <!-- / MC Media Player -->

  2. #2
    Camera Operator/Producer lake54's Avatar
    Join Date
    Jun 2009
    Location
    Manchester, UK
    Posts
    384
    Have you tried using relative links instead? So for example with the script source, assuming you were at the root of your site, the filename would just be "mcmp_0.8.js" type....

    James

  3. #3
    Thanks for the reply James. Yes, tried that and get the same results. When I leave the files set to their default (http://www.mcmediaplayer.com/public/mcmp_0.8.js, etc) the player will actually load, but it will not play the video file. Any other thoughts on what might be going wrong here?

    Christopher

  4. #4
    Camera Operator/Producer lake54's Avatar
    Join Date
    Jun 2009
    Location
    Manchester, UK
    Posts
    384
    Try using the sample code and see if it plays the video.

    If it does play the video, then swap that address for your video. If it doesn't work, then it's likely a referencing issue, so check precisely the location of your video.

    Changing one thing at a time is the best way to solve an issue like this.

  5. #5
    Just to start, your js file is not present , I got a 404 when trying to get it at http://www.kateysfirearmsfacts.com/mcmp_0.8.js.. Your flv video, js file and your html file have to be uploaded first on your remote server at the good locations you specified here to make this work.

  6. #6
    Camera Operator/Producer lake54's Avatar
    Join Date
    Jun 2009
    Location
    Manchester, UK
    Posts
    384
    Also the FLV doesn't appear to load, but I believe that they were when I first tried to help Chris, so I reckon he's moved on.

    James

  7. #7
    James, It's sure after one year, things may change. I know this was outdated but as I got problems with relative paths too, I post my comments. Indeed, relatives path for videos specified by fpFileURL are relative to the directory of playerFile and not to the directory of the html page containing the player. This info will surely save time and headaches for those who are stuck on "Can't find/load url...".

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Subscribe to us on YouTube