Results 1 to 3 of 3
  1. #1
    New Member OldCol's Avatar
    Join Date
    Sep 2010
    Location
    Belleville, IL, USA
    Posts
    1

    Streaming doesn't work in Internet Explorer

    I was excited to learn how to do html streaming.
    I post and stream the Sunday sermons on the church website (I'm the webmaster). However I've found that while the sermons stream in Firefox, Safari, Opera and Chrome they don't stream in Internet Explorer. Unfortunately Internet Explorer comes with all Windows PC's so as a consequence many of the congregation cannot view the sermons.
    The code that I have been using is:
    <object height="360" width="480" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701" classid="clsid:6bf52a52-394a-11d3-b153-00c04f79faa6">
    <param name="Filename" value="http://www.spiritualsuitcase.com/images/stories/VideoSermons/SermonsDrew/090510STPUCC.wmv" />
    <param name="AutoStart" value="true" />
    <param name="ShowControls" value="true" />
    <param name="BufferingTime" value="2" />
    <param name="ShowStatusBar" value="true" />
    <param name="AutoSize" value="true" />
    <param name="InvokeURLs" value="false" /><embed height="360" width="480" invokeurls="false" autosize="true" showstatusbar="true" bufferingtime="2" showcontrols="true" autostart="true" filename="http://www.spiritualsuitcase.com/images/stories/VideoSermons/SermonsDrew/090510STPUCC.wmv" type="application/x-mplayer2"></embed>
    </object>
    Today I found and tried the code below thinking that it might solve the problem
    <object height="360" width="480" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701" classid="clsid:6bf52a52-394a-11d3-b153-00c04f79faa6">
    <param name="FileName" value="http://www.spiritualsuitcase.com/images/stories/VideoSermons/SermonsDrew/091910STPUCC.wmv" />
    <param name="autostart" value="true" />
    <param name="ShowControls" value="true" />
    <param name="ShowStatusBar" value="false" />
    <param name="ShowDisplay" value="false" /><embed height="360" width="480" showdisplay="false" showstatusbar="false" showcontrols="true" autostart="true" filename="http://www.spiritualsuitcase.com/images/stories/VideoSermons/SermonsDrew/091910STPUCC.wmv" type="application/x-mplayer2"></embed>
    </object>
    It works in all of the browser except Internet Explorer. I would appreciate any help you can provide.

  2. #2
    Quote
    Quote: OldCol
    View Post
    I was excited to learn how to do html streaming.
    I post and stream the Sunday sermons on the church website (I'm the webmaster). However I've found that while the sermons stream in Firefox, Safari, Opera and Chrome they don't stream in Internet Explorer. Unfortunately Internet Explorer comes with all Windows PC's so as a consequence many of the congregation cannot view the sermons.
    The code that I have been using is:
    <object height="360" width="480" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701" classid="clsid:6bf52a52-394a-11d3-b153-00c04f79faa6">
    <param name="Filename" value="http://www.spiritualsuitcase.com/images/stories/VideoSermons/SermonsDrew/090510STPUCC.wmv" />
    <param name="AutoStart" value="true" />
    <param name="ShowControls" value="true" />
    <param name="BufferingTime" value="2" />
    <param name="ShowStatusBar" value="true" />
    <param name="AutoSize" value="true" />
    <param name="InvokeURLs" value="false" /><embed height="360" width="480" invokeurls="false" autosize="true" showstatusbar="true" bufferingtime="2" showcontrols="true" autostart="true" filename="http://www.spiritualsuitcase.com/images/stories/VideoSermons/SermonsDrew/090510STPUCC.wmv" type="application/x-mplayer2"></embed>
    </object>
    Today I found and tried the code below thinking that it might solve the problem
    <object height="360" width="480" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701" classid="clsid:6bf52a52-394a-11d3-b153-00c04f79faa6">
    <param name="FileName" value="http://www.spiritualsuitcase.com/images/stories/VideoSermons/SermonsDrew/091910STPUCC.wmv" />
    <param name="autostart" value="true" />
    <param name="ShowControls" value="true" />
    <param name="ShowStatusBar" value="false" />
    <param name="ShowDisplay" value="false" /><embed height="360" width="480" showdisplay="false" showstatusbar="false" showcontrols="true" autostart="true" filename="http://www.spiritualsuitcase.com/images/stories/VideoSermons/SermonsDrew/091910STPUCC.wmv" type="application/x-mplayer2"></embed>
    </object>
    It works in all of the browser except Internet Explorer. I would appreciate any help you can provide.
    I use IE8 & was able to view your video by copying & pasting "http://www.spiritualsuitcase.com/images/stories/VideoSermons/SermonsDrew/091910STPUCC.wmv" in the address bar;
    however, I had to download it into my computer.

    Of course that makes all the bells & whistles of security risks go off, (only some foolish people like me do it anyway) but, I did take the information you provided above & brought it into my HTML editor & placed a code similar to yours & it worked.

    If you paste the code below in Notepad, give it a name & save it as name.html, & then upload it to your server, you will see that it works in any browser.
    Of course, you will have to place a link to it in another page; I'm assuming that you know how to do that.



    Code:
    <html>
    
    <head>
    <title>Type a title for your page here</title>
    </head>
    
    <body bgcolor="#ffffff" text="#000000" link="#ffff00" vlink="#800080" alink="#ff0000">
          <!-- begin embedded WindowsMedia file... -->
          <table border='0' cellpadding='0' align="center">
          <tr><td>
          <OBJECT id='mediaPlayer' width="480" height="405" 
          classid='CLSID:22d6f312-b0f6-11d0-94ab-0080c74c7e95' 
          codebase='http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701'
          standby='Loading Microsoft Windows Media Player components...' type='application/x-oleobject'>
          <param name='fileName' value="http://www.spiritualsuitcase.com/images/stories/VideoSermons/SermonsDrew/090510STPUCC.wmv">
          <param name='animationatStart' value='true'>
          <param name='transparentatStart' value='true'>
          <param name='autoStart' value="true">
          <param name='showControls' value="true">
          <param name='loop' value="false">
          <EMBED type='application/x-mplayer2'
            pluginspage='http://microsoft.com/windows/mediaplayer/en/download/'
            id='mediaPlayer' name='mediaPlayer' displaysize='4' autosize='-1' 
            bgcolor='darkblue' showcontrols="true" showtracker='-1' 
            showdisplay='0' showstatusbar='-1' videoborder3d='-1' width="480" height="405"
            src="http://www.spiritualsuitcase.com/images/stories/VideoSermons/SermonsDrew/090510STPUCC.wmv" autostart="true" designtimesp='5311' loop="false">
          </EMBED>
          </OBJECT>
          </td></tr>
          <!-- ...end embedded WindowsMedia file -->
       </td></tr>
          </table>
    </body>
    
    </html>
    I hope this helps you..........Laura

  3. #3
    I had also faced a same kind of problems while operating Internet Explorer.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Subscribe to us on YouTube