Results 1 to 3 of 3
  1. #1

    Charger not charging, Sharp VL-WD255U

    I have had this camcorder for years, no problems. I got a new battery for it a year or so ago. I put it in the charger this morning, and no green charging light came on. The red power light comes on. The camcorder itself seems to work when plugged into the charger, but the battery doesn't seem to be charging. I put the battery in the camcorder and it first showed about 1/2 a charge, then when I played a bit of tape, the indicator turned red and showed it needed to be charged (This was after I had it plugged in for an hour or so this morning before noticing the green light wasn't on). I tried cleaning off the battery and charger with a cloth, but no changes. Any ideas?

  2. #2
    It seems your charger is working (if it is indeed powering up your camcorder). If so there are a few options:

    1. The contact points of your charger/battery may be oxidised. If it is so, this is easy. Just use a soft eraser (for erasing pencil marks) and rub the contacts. It should work.

    2. Your newly purchased battery is faulty! Seek for a replacement from the dealers whom you purchased it from!
    There's no bad camera, just a bad user
    Loong . Singapore

  3. #3
    I would also suggest looking at the contacts on the charger and the battery.
    Manoni Productions
    Pass me another beer...You are still ugly!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Subscribe to us on YouTube